Delayed Rates
Incident Report for Mortech
Postmortem

During routine Disaster Recover and Business Continuity planning, infrastructure upgrades and maintenance unintentionally changed file permissions resulting in an interruption and delay of rate processing.

The Operations and Data teams identified impacted services and resolved the permission issues.

Posted about 2 months ago. Sep 05, 2019 - 09:01 CDT

Resolved
After extended monitoring, Mortech Operations considers this issue resolved.

We apologize for any delays or inconveniences this has caused.
Posted 2 months ago. Aug 23, 2019 - 12:10 CDT
Monitoring
Rates are now updated for all investors, and we are no longer experiencing delays. We apologize for the inconvenience and thank you for your understanding while we worked to resolve this issue.
Posted 2 months ago. Aug 23, 2019 - 10:04 CDT
Investigating
As Mortech continues additional testing of our Business Continuty Plan (BCP), we are experiencing a service disruption causing a delay in updated rate posting for a limited number of investors.

Our team is currently working to resolve this issue as quickly as possible.

We apologize for the inconvenience and will continue to send updates until the service is restored.
Posted 2 months ago. Aug 23, 2019 - 09:08 CDT
This incident affected: Marksman Rates and Investor Rate Uploads.