Marksman Scheduled System Maintenance
Incident Report for Mortech
Resolved
This incident has been resolved.
Posted Aug 25, 2020 - 08:08 CDT
Identified
Marksman will be undergoing scheduled system maintenance during the hours of 8:00 p.m. - 12:00 a.m. CST on Wednesday, August 19, 2020 & Thursday, August 20, 2020. Users may experience downtime during this time. We apologize for any inconvenience this may cause. Please contact Customer Support at support@mortech-inc.com with any questions.
Posted Aug 18, 2020 - 08:50 CDT
This incident affected: Marksman.