Scheduled System Maintenance
Incident Report for Mortech
Resolved
This incident has been resolved.
Posted May 25, 2023 - 22:00 CDT
Investigating
Mortech will be performing scheduled system maintenance between the hours of 9:00 PM - 11:00 PM CT on Thursday, May 25th. We expect brief and minimal downtime during this maintenance window. Please contact Customer Support at support@mortech.com with any questions.
Posted May 24, 2023 - 17:38 CDT
This incident affected: Marksman, Secondary services, Investor rate uploads, Lead management, Mortech API services, Online marketplace lending, and Partner integrations.