Multiple Mortech Service Disruptions
Incident Report for Mortech
Resolved
The AWS issue has been resolved and we will continue to monitor performance. We apologize for the inconvenience and thank you for your understanding.
Posted Sep 09, 2022 - 13:31 CDT
Investigating
Due to an issue with AWS, multiple Mortech services are now running in a degraded performance state. We are continuing to monitor and will update the status page once resolved. Thank you for your patience.
Posted Sep 09, 2022 - 11:47 CDT
This incident affected: Secondary services, Investor rate uploads, Mortech API services, and Online marketplace lending.