Rate Posting Delays
Incident Report for Mortech
Resolved
Rates are now being updated for all investors, and we are no longer experiencing delays. We apologize for the inconvenience and thank you for your understanding while we worked to resolve this issue.
Posted Jul 14, 2020 - 11:25 CDT
Investigating
We are currently experiencing delays in processing rate updates for a limited number of investors. Our team is working to resolve this issue as quickly as possible. We apologize for the inconvenience and will continue to update the Status page once service is restored.
Posted Jul 14, 2020 - 10:14 CDT
This incident affected: Investor rate uploads.