Secondary Services Disruption
Incident Report for Mortech
Resolved
Mortech secondary services are now performing as expected. We will continue to monitor performance. We apologize for the inconvenience and thank you for your understanding while we worked to resolve this issue.
Posted Jan 31, 2022 - 11:09 CST
Investigating
We are currently experiencing an outage with our historical pricing service. We are investigating this issue and will update the status page once resolved. Thank you for your patience.
Posted Jan 31, 2022 - 10:20 CST
This incident affected: Secondary services.