Investigating AWS Related Service Interruption

Incident Report for Mortech

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:33 CDT

Monitoring

Our services appear to have returned to normal operation as AWS continues to recover from the earlier outage. We’re continuing to monitor performance closely to ensure full stability. If you experience any ongoing issues, please contact Mortech Support at support@mortech.com.
Posted Oct 20, 2025 - 17:00 CDT

Investigating

We’re currently investigating an issue impacting our services due to an ongoing AWS outage. During this time, some Mortech services may be delayed or unavailable. If you are experiencing issues or have urgent needs, please contact Mortech Support at support@mortech.com.
Posted Oct 20, 2025 - 12:17 CDT
This incident affected: Marksman, Secondary services, Investor rate uploads, Lead management, Mortech API services, Online marketplace lending, Partner integrations, and Mortech Protection.