Marksman quoting impacted
Incident Report for Mortech
Resolved
This incident has been resolved.
Posted about 2 years ago. Jul 27, 2017 - 10:19 CDT
Monitoring
Mortech experienced a network issue starting around 8:47am causing Marksman quoting to fail. This issue has been resolved and we are monitoring the situation.
Posted about 2 years ago. Jul 27, 2017 - 09:22 CDT