Investor Rates Delayed
Incident Report for Mortech
Resolved
After continuous monitoring, Operations considers this issue resolved.
Posted over 1 year ago. Feb 21, 2018 - 13:57 CST
Monitoring
Operations has restored service to rate processing and delayed rate files have completed processing. No further delays are expected as we continue to monitor incoming rates.
Posted over 1 year ago. Feb 21, 2018 - 08:49 CST
Investigating
Mortech is experiencing a service disruption affecting investor rate postings collected via email. During this time, investor rate updates will be delayed.

Our team is currently working to resolve this issue as quickly as possible.

We apologize for the inconvenience and will continue to send updates until the service is restored.
Posted over 1 year ago. Feb 21, 2018 - 08:41 CST