Mortech MI Service Disruption

Incident Report for Mortech

Resolved

We are no longer experiencing a service disruption with MI quoting. We apologize for the inconvenience and thank you for your understanding while we worked to resolve this issue.
Posted Feb 22, 2021 - 14:35 CST

Investigating

We are currently experiencing a service disruption with MI quoting. Our team is working to resolve this issue as quickly as possible. We apologize for the inconvenience and will continue to update the Status page once service is restored.
Posted Feb 19, 2021 - 17:10 CST
This incident affected: Marksman.