All Rates Expired, Rates Currently being Reposted
Incident Report for Mortech
Resolved
All rates have reposted.
Posted almost 2 years ago. Nov 16, 2017 - 11:21 CST
Investigating
Due to a rate system disruption all rates are currently reposting and expect to be restored within 15 minutes. This is not an investor reprice. Please contact support@mortech-inc.com with any questions.

Be advised, rate notification emails have been sent with subject "Pricing Update," however there were no impacts on the accuracy or timeliness of rates data or associated market changes.
Posted almost 2 years ago. Nov 16, 2017 - 10:26 CST