Investor Rate Postings Delayed
Incident Report for Mortech
Resolved
Rate collection issues for affected investors have been resolved.
Posted over 1 year ago. Jun 22, 2018 - 23:47 CDT
Monitoring
Rate collection processes have been addressed with investors and we continue to monitor rate collection. Rate delays may still occur.
Posted over 1 year ago. Jun 22, 2018 - 15:05 CDT
Identified
Due to Mortech office connectivity issues, rate processing and staff accessibility is causing delays in rate collection for two investors. We are actively working with these investors to collect rates. Please contact support if you feel your investor is also affected.
Posted over 1 year ago. Jun 22, 2018 - 11:50 CDT
Investigating
Mortech is currently experiencing delayed rate posting for some Mortech supported investors.

Our team is currently working to resolve this issue as quickly as possible.
We apologize for the inconvenience and will continue to send updates until the service is restored.
Posted over 1 year ago. Jun 22, 2018 - 11:12 CDT
This incident affected: Investor Rate Uploads.